Jump to content
Snap66

How to resolve Volume and Wah expression pedal conflict

Recommended Posts

I have several presents where I want the volume pedal and the wah. When I add these blocks to the path it automatically assigns the volume to exp2 and Wah to exp1. To change between you use the toe switch on the pedal. 

 

This is all good except as it's in volume mode as default I have to press the pedal all the way forward to activate the hidden toe pedal to get to the wah. 

 

The problem is now I'm at 100% volume as I've had to push the volume pedal all the way forward to get to the tow switch ie all my spare headroom, and it's too loud. 

 

Any suggestions please. 

 

Thanks

Share this post


Link to post
Share on other sites
6 hours ago, Snap66 said:

Any suggestions please. 

 

For full control and independence between the two, you need to hook up an external expression pedal. By default, the external pedal will be EXP2 (volume) and that leaves the built in pedal to control EXP1. The toe switch engages the wah... the expression controls it. When the wah is disengaged (again by the toe switch) the pedal becomes ineffective. The VOLUME pedal (EXP2) is completely separate and always works as expected.

Share this post


Link to post
Share on other sites
11 hours ago, Snap66 said:

I have several presents where I want the volume pedal and the wah. When I add these blocks to the path it automatically assigns the volume to exp2 and Wah to exp1. To change between you use the toe switch on the pedal. 

 

This is all good except as it's in volume mode as default I have to press the pedal all the way forward to activate the hidden toe pedal to get to the wah. 

 

The problem is now I'm at 100% volume as I've had to push the volume pedal all the way forward to get to the tow switch ie all my spare headroom, and it's too loud. 

 

Any suggestions please. 

 

Thanks

 

You can set minimum and max settings for your volume pedal. If you reverse them so that the minimum is the higher number then when you press the pedal down to activate the wah it will put your pedal back to normal volume.

 

The only downside to this is you have to think of your volume in reverse. Raising it makes it louder, instead of quieter.

Share this post


Link to post
Share on other sites
15 hours ago, Snap66 said:

The problem is now I'm at 100% volume as I've had to push the volume pedal all the way forward to get to the tow switch ie all my spare headroom, and it's too loud. 

 

After thinking about your post a bit....  it would be really good to know how you actually use your volume pedal! 

  • Is your volume always too loud when you put your volume pedal up full? If it is... lower the range of the volume pedal so it is only 60% or 80%.... whatever volume you require. Or... lower the volume of your patch so you can leave it at 100%. 
  • Is it only too loud when you engage the wah? If so... turn the LEVEL on the wah block down so it's the correct volume. Should you require a little extra later (with the wah block on), just add a boost block somewhere in the chain that you can turn on/off as needed.

 

  • Like 1

Share this post


Link to post
Share on other sites

Not sure about operating the volume pedal in reverse apart from it being weird I suspect I would endd up eitb no volume. I will play around with an external pedal but I just bought the Helix to avoid all that additional stuff. 

Share this post


Link to post
Share on other sites
33 minutes ago, Snap66 said:

Not sure about operating the volume pedal in reverse apart from it being weird I suspect I would endd up eitb no volume. I will play around with an external pedal but I just bought the Helix to avoid all that additional stuff. 

 

Well, it does depend upon how you set the parameters. When I do it, volume is more of a boost, so when I move it to the minimum I don't have no volume, it puts it back down to my normal level. 

 

Anyway, codamedia's suggestion is a good one I'll have to fiddle with.  I never thought of setting the levels of the wah different. 

Share this post


Link to post
Share on other sites
On 4/27/2019 at 6:10 AM, Snap66 said:

I have several presents where I want the volume pedal and the wah. When I add these blocks to the path it automatically assigns the volume to exp2 and Wah to exp1. To change between you use the toe switch on the pedal. 

 

This is all good except as it's in volume mode as default I have to press the pedal all the way forward to activate the hidden toe pedal to get to the wah. 

 

The problem is now I'm at 100% volume as I've had to push the volume pedal all the way forward to get to the tow switch ie all my spare headroom, and it's too loud. 

 

Any suggestions please. 

 

Thanks

 

There is a handy method you can use to do this just with the Helix's expression pedal. It simply requires connecting a MIDI cable from the Helix's MIDI out to its MIDI in connection. You are going to leverage a MIDI command using the CC#59 value which acts just like pressing the expression pedal's toe switch when it is sent back into the Helix.The  MIDI command will be assigned to the footswitch you want to use to switch from volume to wah. That way you can use any footswitch you want to switch from the volume to the wah and back and the volume will remain wherever you had it set before you switched to the wah. The expression pedal will simply switch over to controlling the wah instead of the volume pedal. The volume pedal block will remain active but its volume won't change while you rock the wah.

 

 

You can download the preset for setting this up from CustomTone: https://line6.com/customtone/tone/4397153/

If you use the preset you only need to follow the steps #1&2 below. Set 'Global Settings' --> 'MIDI/Tempo' --> 'MIDI Thru' = "Off" and then loop a MIDI cable from your Helix's MIDI output to your Helix MIDI input.

 

If you prefer to set it up yourself the complete instructions are below.

 

Instructions below use HX Edit for several steps but they could also be done from the Helix directly. You can substitute the references to footswitch#11 for whichever footswitch you prefer to use. Please let me know if I omitted anything or got it wrong but my preset appears to work correctly.

  1. Set 'Global Settings' --> 'MIDI/Tempo' --> 'MIDI Thru' = "Off"              This prevents runaway infinite loop MIDI funkiness when you are looping MIDI back into the Helix
  2. Set up a MIDI cable from your Helix MIDI output and loop it back to your Helix MIDI input
  3. Add your wah and volume block using the Helix's default settings for your volume on EXP2 and wah on EXP1. The volume block should be active, wah should be bypassed, and the text above the expression pedal should have EXP2 highlit.
  4. Use HX Edit and go to the 'Bypass Controller Assign' tab and change the assignment for your Wah block for the 'Bypass' parameter to the footswitch you want to switch from volume to wah. In this example I will use footswitch#11.
  5. While you are still on the 'Bypass Controller Assign' tab clear the assignment for the Volume block's 'Bypass' parameter. So now you should be looking at three assignment entries only for both the volume and wah blocks - Wah Position = EXP1, WAH Bypasss = Footswitch#11 (used in this example) and Volume Position = EXP2
  6. Now go to the Command Center (where you set up your MIDI commands) and set up the following values in the parameters for Footswitch#11(used in this example)
    1. Command = "MIDI CC",  MIDI Ch = "Base",  CC# = 59,  Value = 0
    2. The Helix uses the CC# "59" to switch between EXP1 and EXP2 on the expression pedal. Handy as we will no longer be using the toe switch. It is this capability that allows the expression pedal's control to be passed from the volume to the wah pedal without turning the volume block off. This preserves the volume pedal's last setting.
  7. As we are using footswitch #11 in this example which is on the bottom row next to the  tuner switch, you are going to need to have your global settings set for Stomps on the bottom row or you need to switch into Stomp mode so you can use footswitch#11.
  8. You are done. Use footswitch#11 to switch between volume and wah. Don't use the expression pedal toe switch! Now when you press footswitch#11 (used in this example) the expression pedal will control only the wah or only the volume. Also, when you switch from volume to wah your volume will be retained at the same level without maxing out.

VolWah on FS#11.hlx

  • Like 3
  • Upvote 2

Share this post


Link to post
Share on other sites
10 minutes ago, Snap66 said:

Wow that's a creative solution thanks I will give that a go

 

Great! Let me know how it goes. Made an edit to step#3 and also labeled FS#11 in the preset "Vol/Wah" to make things a bit clearer. Seems to be working just fine for me.

Share this post


Link to post
Share on other sites

That's a great solution!!!

 

I never really liked switching wah on via the toe switch (even on 'physical wah stomps') and preferred to activate that effect the same way as all the others.

 

A little unfortunate is that there is no 'internal Midi loopback' in the Helix, but i can live with that.

Share this post


Link to post
Share on other sites
On 4/28/2019 at 3:02 AM, HonestOpinion said:

 

There is a very cool method you can use to do this just with the Helix's expression pedal. It simply requires connecting a MIDI cable from the Helix's MIDI out to its MIDI in connection. You are going to leverage a MIDI command using the CC#59 value which acts just like pressing the expression pedal's toe switch when it is sent back into the Helix.The  MIDI command will be assigned to the footswitch you want to use to switch from volume to wah. That way you can use any footswitch you want to switch from the volume to the wah and back and the volume will remain wherever you had it set before you switched to the wah. The expression pedal will simply switch over to controlling the wah instead of the volume pedal. The volume pedal block will remain active but its volume won't change while you rock the wah.

 

 

You can download the preset for setting this up from CustomTone: https://line6.com/customtone/tone/4397153/

If you use the preset you only need to follow the steps #1&2 below. Set 'Global Settings' --> 'MIDI/Tempo' --> 'MIDI Thru' = "Off" and then loop a MIDI cable from your Helix's MIDI output to your Helix MIDI input.

 

 

I just have to say, if they gave out Academy Awards for gear creativity solutions, this would be the 2019 winner. Nice. 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Is there any other solution for this? I use my MIDI out port to send commands to another pedal.

 

I sing and play guitar and sometimes I switch from a singing chorus to a guitar-focused instrumental part and I want to engage the wah. The issue is that changing the EXP using the toe switch requires some force and its not always smooth to hop on the pedal and do that when I'm also glued to the mic. Being able to hit FS7 for example to change the EXP would be great.

 

Any other solutions?

 

Edit: just saw that there is an entry on ideascale at the link below

 

https://line6.ideascale.com/a/dtd/Toggle-Expression-Pedal-selection-with-Footswitch/967640-23508

Share this post


Link to post
Share on other sites
1 hour ago, kevin627 said:

Is there any other solution for this? I use my MIDI out port to send commands to another pedal.


I use snapshots for this - one snapshot with the wah bypassed and another with the wah engaged.
 

I also sometimes want the behavior of the Bad Horsie wah, which disengages the wah when you release your foot from the pedal. The option I use for this is an external expression pedal, spring-loaded, with the wah always engaged, but using the Wait and Position parameters to turn it off when it returns to the heel position.

Share this post


Link to post
Share on other sites

You can assign it to a different footswitch so you don't have to use the expression pedal toe switch. Just assign both the volume and wah to the same footswitch. You just have to make sure the on/off states for the volume and wah are opposite of each other.

Share this post


Link to post
Share on other sites

The solution below is excellent and I have used it on my unit to have separate control of a switchless wah on EXP1 (using a 5% bypass trigger), and then speed control of a Rotary effect on EXP2. Assigning the MidCC59 change in the Command Centre to facilitate button 2 to make the switch on EXP's as well as switching on the Rotary has been a revelation.

 

However.........it suddenly stopped doing this, and now i don't seem to be able get the Midi command to do what it's supposed to do, and also the toe switch doesn't seem to doing anything either. I've gone back over all the settings and it 'seems' (not withstanding user error :-) that I've got everything as it should be.

 

Is anyone, or has anyone experienced any challenges of a similar ilk developing with this solution?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...