Jump to content
Digital_Igloo

Helix FW 1.04.1 (and Helix App 1.02) Now Available

Recommended Posts

Helix Firmware v1.04.1 Release Notes


IMPORTANT! Before restoring your backed up presets to Helix, you must first install the latest version of the Helix application!

Helix v1.04.1 is a free firmware update that includes new delay models, features, fixes, stability improvements, and optimizations. It is highly recommended that all Helix users perform this update!

It is also recommended that you back up your current presets by using the Helix application to create a preset bundle, allowing you to install new presets as part of the update process.

The easiest way to perform the update process is by installing the latest version of Line 6 Updater. Once you've connected Helix to your computer via its USB port (hubs are not supported), Line 6 Updater will recognize the unit and take you through the update process. TheLine 6 Updater application may be downloaded here: http://line6.com/software/


Resetting Helix Globals / Loading the Newest Factory Presets
IMPORTANT! This procedure will completely overwrite all existing presets and setlists, as well as clear all user IRs and reset all global settings! Back up your presets and IRs before proceeding!

  1. Turn off Helix.
  2. While holding footswitches 9 and 10 (middle two switches on the bottom row), turn on Helix. Wait for the message “Will reset Globals and restore stock Presets, Setlists and IRs…†to appear and let go.

New Effects Models

  • Delay > Dual Delay (Stereo): New Line 6 Original stereo delay with separate time, feedback, and mix per channel. Includes high and low cut filters and Chorus or Vibrato modulation
  • Delay > Reverse Delay (Mono, Stereo): New Line 6 Original; whatever you play in comes back at you backwards (up to four seconds mono, two seconds stereo)

New Features

  • Added the ability to determine how Helix’s delay blocks respond to tap tempo. Select “Authentic†(default) or “Transparent,†which minimizes natural pitch fluctuations. This new parameter is found here: Global Settings > MIDI/Tempo > Page 2: Knob 1 (Tap Tempo Pitch)
  • Added the ability to determine whether Helix’s expression pedal positions are recalled per preset (default) or applied globally. This new parameter is found here: Global Settings > Footswitches > Knob 5 (EXP Pedal Position)

Bug Fixes

  • Copying and pasting a Wah block would reset its Position parameter’s Min and Max values â€”FIXED
  • When moving delay or mod blocks past an amp or cab block, any time or speed parameters set to note divisions would sometimes reset â€”FIXED
  • The inspector view graphics could appear incorrect and UI elements could overlap after TAP is touched and a preset is loaded in the Preset menu â€”FIXED
  • Repeated touches of a footswitch may not cycle properly when assign as a controller for multiple parameters â€”FIXED
  • When reordering presets, the preset’s previous destination could load after a power cycle â€”FIXED
  • In some cases, Factory Restore may not erase custom setlist names â€”FIXED
  • General stability improvements
  • Other minor bug fixes and optimizations

Other Improvements

  • When selecting “Per Preset†Variax settings, Variax Volume Knob and Variax Tone Knob now both default to Don’t Force instead of 0.0
  • In the rare case of a freeze, Helix can now restore by clearing only the current preset instead of resetting all presets. While holding footswitches 11 and 12, turn on Helix

Known Issues

  • Assigning a custom label to the EXP Toe Switch scribble strip disconnects wah blocks’ Position parameter from EXP 1; can be manually reassigned
  • Pressing BYPASS while viewing the Model List > Looper category can invert Looper footswitch behavior
  • While a loop is playing, changing from a preset with the Looper block on Path 1 to one with the Looper block on Path 2 may cause a small portion of the recorded loop to play
  • Minor pops and clicks may be present when Helix is streaming audio from a Mac® running OS X 10.11.1 (El Capitan)
  • Minor pops and clicks may be present when Helix is streaming audio from an iOS® device running iOS 9 with Apple® Camera Kit
  • Importing a Helix bundle while streaming audio over USB may cause the Helix application to disconnect
  • In rare cases, Amp+Cab or Cab > Dual parameter graphics may overlap the action panel buttons while in Pedal Edit mode
  • Upvote 1
  • Downvote 4

Share this post


Link to post
Share on other sites

 

Helix Firmware v1.04.1 Release Notes

IMPORTANT! Before restoring your backed up presets to Helix, you must first install the latest version of the Helix application!

 

...

Resetting Helix Globals / Loading the Newest Factory Presets

IMPORTANT! This procedure will completely overwrite all existing presets and setlists, as well as clear all user IRs and reset all global settings! Back up your presets and IRs before proceeding!

  1. Turn off Helix.
  2. While holding footswitches 9 and 10 (middle two switches on the bottom row), turn on Helix. Wait for the message “Will reset Globals and restore stock Presets, Setlists and IRs…†to appear and let go.

...

 

Awesome to see the latest version of the firmware out DI, thanks! I have a question.  When you use the Updater the instructions for this release 1.04.1 say to press the 7&8 buttons to update to the new factory presets. Which method should we use 7&8 per the instructions in the firmware or 9&10 per the instructions here?

 

Also, the verbiage here is confusing as it says "restore stock Presets" under point number 2.  "Stock" presets is a term used by many manufacturers to indicate the presets that remain permanently embedded on a firmware chip when the hardware is first shipped from the factory, such that if all else fails, you can always return to the state the hardware shipped in. I think it would be less confusing if "Stock" and "Newest Factory" were not used interchangeably. But then, I am easily confused. Thanks!

Share this post


Link to post
Share on other sites

7 and 8 update only the presets; 9 and 10 update the presets and some behind-the-scenes global settings (as well as the user-facing Global Settings). 9 and 10 is a cleaner update, but you'll have to manually reset your Global Settings.

 

Good call on the "stock vs. factory" confusion. I'll make a note. Thanks!

Share this post


Link to post
Share on other sites

7 and 8 update only the presets; 9 and 10 update the presets and some behind-the-scenes global settings (as well as the user-facing Global Settings). 9 and 10 is a cleaner update, but you'll have to manually reset your Global Settings.

 

Good call on the "stock vs. factory" confusion. I'll make a note. Thanks!

 

Grin, thanks, you rock!

Share this post


Link to post
Share on other sites

My helix read on my PC ( win 10) 1st try today😀

Update was easy this time

Share this post


Link to post
Share on other sites

My helix read on my PC ( win 10) 1st try today

Update was easy this time

 

Mine also updated on Windows 10 with no issues and no "Knack" errors on the Helix or the Helix app when I restored my custom presets. For those who have not updated yet, as stated in DI's earlier post, make sure you back up your custom presets with the new Helix app version 1.02 before upgrading to the new firmware.  You may want to make sure you back up to a different name with the 1.01 Helix software before you upgrade to 1.02 some users seem to have had issues with OS X . Probably worth your while to just make sure you have backups of your custom presets made with both the 1.01 and 1.02 versions of the Helix app to be on the safe side.

 

I used a Windows 10 box for the update.  I backed up my custom presets to a different name after my firmware upgrade as well before I ran the footswitch 9&10 reset. As designed you will have to reset your global settings if you use the 9&10 reset procedure.

Share this post


Link to post
Share on other sites

Can't do update  :(

 

Helix app 1.02 won't connect. So, I can't backup my presets. USB audio connects/works fine.

 

Tried rebooting and re-install. No go.

 

I'm on OS X 10.10.5

 

Any ideas boys?

 

Guess I'll try with my PC (Yikes :rolleyes:  )

Share this post


Link to post
Share on other sites

.... For those who have not updated yet, as stated in DI's earlier post, make sure you back up your custom presets with the new Helix app version 1.02 before upgrading to the new firmware.....

I don't have Helix so can't test this out, but as I read DI's info it says that you need to use the new app v1.02 to RESTORE the previously backed up presets. It does not say that you need to use the new app to create the backup. I would think it makes most sense to use the old app with the old firmware to backup and then the new app with the new firmware to restore.

 

Any clarification on this from other users who have already backed up and restored? Which version of the app did you use to make the backup before updating?

Share this post


Link to post
Share on other sites

I updated tonight with no issues (win 10) but didn't do any of the dual footswitch resets.  The install said it rebuilt all my presets so am I missing anything by not doing the full reset?  I really don't care if there are any new factory presets, I prefer making my own anyways.

 

The new delays and features are awesome!  Really digging this Helix, especially the Divided by 13 amp...

Share this post


Link to post
Share on other sites

I don't have Helix so can't test this out, but as I read DI's info it says that you need to use the new app v1.02 to RESTORE the previously backed up presets. It does not say that you need to use the new app to create the backup. I would think it makes most sense to use the old app with the old firmware to backup and then the new app with the new firmware to restore.

 

Any clarification on this from other users who have already backed up and restored? Which version of the app did you use to make the backup before updating?

 

Great catch! Edited my original post accordingly.  You are right the Release Notes for the upgrade are a bit ambiguous there. I assumed I was supposed to save and restore with v.1.02 and that seems to have worked on Windows 10, but maybe that was not a safe assumption. Not sure if you were supposed to save with 1.01 and restore with 1.02. That could quite possibly be the intended procedure if you execute the Release Notes exactly as written.

 

I saved with both, I saved my custom presets with the 1.01 version of the Helix app, just in case the update failed and I had to restore to earlier firmware. I then upgraded to the 1.02 version of the Helix app and saved my presets under a different name.  Then I upgraded to firmware 1.04.1 and saved my custom presets yet again with a different name with 1.02. Probably a little overly cautious that way. I then ran the 9&10 reset and then restored my presets from the v.1.02 backup using Helix app v1.02. So...I used v.102 of the Helix app for both the save and the restore on Windows 10.

 

What is the correct procedure L6? Does it matter if we save with v.1.01 or v.1.02 of the Helix app and then restore with v.1.02?

Share this post


Link to post
Share on other sites

Can't do update  :(

 

Helix app 1.02 won't connect. So, I can't backup my presets. USB audio connects/works fine.

 

....

Try reinstalling the previous version of the app and using that to backup your current presets. Then update both app and firmware as per documented procedures.

Share this post


Link to post
Share on other sites

Try reinstalling the previous version of the app and using that to backup your current presets. Then update both app and firmware as per documented procedures.

 

Thanks. 

 

Upgrade worked with Win7 PC.

 

Don't know why the OS X doesn't work now and still. That never happened before.

Share this post


Link to post
Share on other sites

Helix Firmware v1.04.1 Release Notes

 

IMPORTANT! Before restoring your backed up presets to Helix, you must first install the latest version of the Helix application!

...

Could you please make it clearer whether the backup of presets should be done with v.1.02 or v.1.01 of the Helix app. Does it make a difference whether I restore from a v.1.01 backup or a v.1.02 backup after I have upgraded to firmware v.1.04.1? I assume I should use the v.1.02 Helix application for the restore either way per the Release Notes but can I use either version's saved backup?

Share this post


Link to post
Share on other sites

 

Helix Firmware v1.04.1 Release Notes

...

Known Issues

  • Assigning a custom label to the EXP Toe Switch scribble strip disconnects wah blocks’ Position parameter from EXP 1; can be manually reassigned
  • ....

 

I don't think "manually reassigning  to EXP 1" as stated in the Release Notes works, at least on my Helix or unless I am not executing the custom naming procedure correctly.  Maybe the intent of this "Known Issues" note was to say that after adding a customized name and losing wah pedal operation it could be restored by removing the custom name and making sure the volume and wah blocks are properly assigned.

 

Once I have customized the toe switch name , even if I manually reassign the wah block's position parameter to EXP 1, I still cannot get the expression pedal to work properly with both the wah and the volume pedal. This effectively renders custom naming of the toe switch unusable for me. Btw, on my Helix, after a custom toe switch name, the Wah pedal still shows that it is assigned to "EXP Pedal 1" for the position parameter, it is just not reflected in reality by having the expression pedal able to control the Wah and position parameter. As before, clicking "Remove" on the customized name restores normal operation to the expression pedal for the wah. Does anyone have a procedure that enables the wah and volume pedal to work with the expression pedal once the toe switch name is customized?

 

Less importantly but I thought it worth mention, the grayed out custom name reflects the name of the EXP 2 assignment (by default volume), not EXP 1 (wah), which seems kind of counter-intuitive. For proper operation with a custom name without swapping assignments around you would have to use "Volume" as your custom name.

 

Once you customize your toe switch name to be for instance "WAH", you would actually have to reverse the default assignments for the wah and volume pedal blocks of the Helix to "EXP Pedal 1"="Volume" and "EXP Pedal 2"="wah". Otherwise, when your custom name "WAH" is toe clicked from greyed out to bold display, it will be your volume that is being controlled by the pedal rather than your "WAH". This may seem like a minor detail but I would imagine most people will want to use the custom name to indicate whether they are switching between the volume pedal and some other effect/parameter such as a wah, pitch bend, parameter like "Rate" or "Mix", etc..  They will assume that the grayed out custom name is the volume pedal by default. Once again to achieve this operation you will have to swap the default EXP1 and EXP2 assignments for the volume pedal and whatever you chose to operate on EXP1. To sum up, by default, the volume pedal (by default assigned to "EXP Pedal 1") should have the grayed out custom name and the effect/parameter you have assigned to "EXP Pedal 2" should be the bolded custom name.

 

Ultimately I hope this will be all moot as L6 already has some better ideas of how to implement custom labeling and enhanced operation of the toe switch scribble strip.

 

 

Will be glad to see a fix for this in a future update. Would loved to have seen a fix in this update but I understand that there are other higher priorities right now.

Share this post


Link to post
Share on other sites

Did the update on Windows 10 without a glitch. Restored my set lists after rebooting with 9-10 down.

Everything looks good.
Thank you!

Share this post


Link to post
Share on other sites

Great news with an update. :)

I'm hoping that these two items will remove my regularly appearing Black Screen Of Death:

 

Bug Fixes

  • General stability improvements
  • Other minor bug fixes and optimizations

Other Improvements

  • In the rare case of a freeze, Helix can now restore by clearing only the current preset instead of resetting all presets. While holding footswitches 11 and 12, turn on Helix

 

I also hope that the updated Helix application will now allow me to back up presets on the PC.

This would make the Helix usable for me at band practice.

 

I'm really keeping my fingers crossed on this. I've had a string of bad luck incidents with my floor boards lately. :(

First the Helix didn't work reliably out of the box (regular BSOD and no ability to back up presets in the PC app)

Then the previous saturday my HD500 died on me when setting up for a gig. It writes Update Flash in the display and won't boot. I've tried to update the flash 5 times with Monkey reporting update success, but it always boots with the same "Update Flash" message and freezes.

With four hours to go before the gig I had to bring out my old X3-live board and recreate the 24 patches I use, which was a bit too exciting for me.

I've played the last two gigs (this saturday and previous saturday) with the X3-live, and I survived but it wasn't fun with all these last minute changes. :(

 

I'm updating tonight ... whish me luck. :)

 

Soren

 

PS: If my X3-live blows then I'm down to my very old XT-live, and I absolutely don't want to go there. :mellow:

Share this post


Link to post
Share on other sites

Updateing Helix software to 1.02 --- CHECK!

Exporting my presets to hardware --- CHECK!

 

Updateing Helix firmware ....... not so much. It crashes and crashes and asks to reboot and go again. Once it even got a tiny-winy bit further in the process but still, crash and please try again. Using OSX 10.9.4 and yes the effin USB cable is directly between the helix and mac, not using a hub or anything... Doing everything just like I'm asked to do but not working at all.

 

It was exactly the same when I was updateing the helix from stock to 1.03 - it took me like 15 times to plug in and out and reboot and retry and... really, this shouldn't take all day!!!

 

Once I get this working I might just wait for version 2.xx before doing BETA WORK LIKE THIS :C

Share this post


Link to post
Share on other sites

Anyone with OS X have success with the update? I'm on 1.03 without issues and away on holiday but plan on updating when I return.

Share this post


Link to post
Share on other sites

Exported my presets in 1.01

Updated Helix software to 1.02

Updated Helix to 1.0.4.1

Did the 9-10 switch thingy

Imported presets.

All fine!

All on Windows 10

Share this post


Link to post
Share on other sites

Thinking about the consequences of the dreaded BSOD this new feature could be a very welcome addition:

Other Improvements

  • In the rare case of a freeze, Helix can now restore by clearing only the current preset instead of resetting all presets. While holding footswitches 11 and 12, turn on Helix

 

If you always remember to switch to an unused preset before turning the power off, you might get away with just resetting the unused preset every time you get a BSOD? That would indeed be a manageble work-around to mitigate the consequences of a reset.

Share this post


Link to post
Share on other sites

Thinking about the consequences of the dreaded BSOD this new feature could be a very welcome addition:

 

If you always remember to switch to an unused preset before turning the power off, you might get away with just resetting the unused preset every time you get a BSOD? That would indeed be a manageble work-around to mitigate the consequences of a reset.

I wonder if the switch to a blank preset before power down would be a work around in itself..

Share this post


Link to post
Share on other sites

Is the purpose of the dual delay just to free up a block?? I am not totally getting the purpose otherwise. I have been using two delays since day one with the Helix with fantastic results. In fact I think it sounds better that way.. I am not complaining. I appreciate more options. I am just wondering the thought process and also what it is modeled after.. If course I didn't have a ton of time to play so I may nail it with tweaks.. I have been using the transistor delAy and elephant man combo with plate delay for my U2 stuff so far.

Share this post


Link to post
Share on other sites

One more quick question for the L6 guys here.. Is there any reason to reset/ the stock presets in this version. Did theyvgetctweajed in any way. My upgrade went flawless without resetting them.

Share this post


Link to post
Share on other sites

Looking for a thread, but couldn't find one concerning this topic. When ShouldHelix owners expect a new editor? Hoping it will be like the Hd model editors..

 

Thanks in advance!

Share this post


Link to post
Share on other sites

This helped me:

 

- quitting logic from the background

- instead of rebooting helix - as instructed - I kept pushing the update in updater software without any reboot.

Share this post


Link to post
Share on other sites

Exported my presets in 1.01

Updated Helix software to 1.02

Updated Helix to 1.0.4.1

Did the 9-10 switch thingy

Imported presets.

All fine!

All on Windows 10

Same here. Worked flawlessly. And I have tree full banks of user presets.

Share this post


Link to post
Share on other sites

Updateing Helix software to 1.02 --- CHECK!

Exporting my presets to hardware --- CHECK!

 

Updateing Helix firmware ....... not so much. It crashes and crashes and asks to reboot and go again. Once it even got a tiny-winy bit further in the process but still, crash and please try again. Using OSX 10.9.4 and yes the effin USB cable is directly between the helix and mac, not using a hub or anything... Doing everything just like I'm asked to do but not working at all.

 

It was exactly the same when I was updateing the helix from stock to 1.03 - it took me like 15 times to plug in and out and reboot and retry and... really, this shouldn't take all day!!!

 

Once I get this working I might just wait for version 2.xx before doing BETA WORK LIKE THIS :C

 

 

 

I have had the same problem on every Helix update I have done. It takes 2-3 attempts to update. I have never had the 1st update attempt work. The strange thing is I am running Windows 10. I seem to be the only one running 10 that has had a problem. It makes me sweat a little bit every time I do an update. :(

Share this post


Link to post
Share on other sites

I have started downloading the update first then updating. This should prevent any Internet connection issues which could occur. Something I learned as a tech support guy many years ago with any version was to go into task manager and close any program I don't need.. If you see something you are unsure if leave it alone as you do not want to stop system files.. It's basically line doing it in safe mode then. To often things share resources and screw up updates.. More often than not we blame line 6 when it is another program that is the culprit. Just because it's closed doesn't mean it isn't in memory. I have started the task manager and had six Iexplorer running

  • Upvote 1

Share this post


Link to post
Share on other sites

I wonder if the switch to a blank preset before power down would be a work around in itself..

 

It's certainly worth a try, although loosing an unused patch to a power on reset wouldn't be a major issue for me. It would be an acceptable work around until they can iron out the bugs in this thing. :)

Share this post


Link to post
Share on other sites

Whatever the problem is with the PC program, it's still there after updating to version 1.02.  :(

When trying to save an empty preset the program crashes with a Windows error message that the Helix program has stopped working, so still no possibility to backup presets, set lists or bundles.

 

I did get the 1.04.1 firmware installed correctly, so now I need to check if the BSOD is gone with this update.

 

It would have been nice to have the possibility to back up presets though.  :mellow:

Share this post


Link to post
Share on other sites

just did update - as far as the APP goes...the install was full of errors - too many to note...click ignore 30X - then it says successfully installed (Win8) Then plug/unplug a couple times to get app to recognize helix

Share this post


Link to post
Share on other sites

I've found that to install the app on my computer (win 10) I have to uninstall the older version or it will give tons of errors. Once you uninstall everything, then the install goes nice and easy.

Share this post


Link to post
Share on other sites

After multiple failed updates from 1.01 to 1.04 I on Windows 7 I finally ran the upload from a local file and this did the trick. It appears there were time out issues when running the update using an online file.

Share this post


Link to post
Share on other sites

I'm confused on how to do the upgrade.  I can't find the link for the Line 6 Updater Software.  I already have the Line 6 Monkey, and that doesn't have an option for the Helix.

 

How do you actually update this firmware?

Also, is there a computer application software for the Helix?

 

Steve

Share this post


Link to post
Share on other sites

You will find Line 6 Updater in the software downloads section of this website (under the Support tab at the top of this page). Choose Line 6 Updater in the software field of the search area. You will also find Helix editor/librarian to download.

Share this post


Link to post
Share on other sites

Anyone with OS X have success with the update? I'm on 1.03 without issues and away on holiday but plan on updating when I return.

 

Yeah, I did.  After I got my Helix, I *REVERTED* from El Capitan back to the last version of Yosemite.

 

Before reverting, my Mac couldn't "see" the Helix.  Afterwards, smooth sailing.

 

http://line6.com/support/topic/16894-helix-usb-and-the-mac/

 

I won't update to El Capitan (again) until things with the Helix are straightened out.

Share this post


Link to post
Share on other sites

I'm confused on how to do the upgrade.  I can't find the link for the Line 6 Updater Software.  I already have the Line 6 Monkey, and that doesn't have an option for the Helix.

 

How do you actually update this firmware?

 

Also, is there a computer application software for the Helix?

 

Steve

Hello, my Line 6 Monkey does not know helix. It is not in the list. So I can not find it with Cubase for recording audio.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×