Jump to content

[SOLVED] Installed 2.8, Helix Rack bricked. Can't roll back. Boot Mode does fail.


PierM
 Share

Recommended Posts

I followed every single word and step as described in the sticky update post.

 

I've got a install failure while updating to 2.8 (helix rack, with controller turned off). Also the updated stopped, for an error.

 

Reboot in boot mode and tried again, the install does stop at 5% and fail again.


Tried rolling back to 2.7 or an earlier firmware in boot mode, keep failing at 5%.

 

Please help, this is a fresh unit with 3 days of life....

  • Confused 1
  • Upvote 1
Link to comment
Share on other sites

Hopefully you have backups as some of these wipe out presets but I would start rolling through the global reset options for your device.

 

Edited: There were some excellent solutions added after I posted this initially so please look at phil_m and some of the other posters' solutions before you resort to global reset options. These are for when all else fails.

Reset Options

Helix Floor/LT

Button Combination Description
2 LED light Fun
3 & 4 Test Mode
5 & 6 Global reset
7 & 8 Reset setlists to factory, Keep IRs
8 & 9 Reset setlists to factory, Clear IRs
9 & 10 Reset setlists to factory, Global reset, Clear IRs
10 & 11 Upgrades existing presets to latest format
11 & 12 Clear current preset
5 & 12 Clear setlists, clear IRs, Return system settings to default
6 & 12 Safe boot mode

To use Reset Options:

  • Power off the Helix
  • Hold the desired button combination
  • Power on the Helix
  • Release the button combination

Please note: Buttons are numbered from top left to bottom right.

Helix Rack

Since the rack doesn’t have footswitches, you’ll instead hold down a combination of the 6 encoders that are below the main LCD screen as you’re booting up.

Button Combination Description
ENC2 & ENC3 Reset globals
ENC3 & ENC4 Restore stock presets and setlists
ENC4 & ENC5 Restore stock presets, setlists, and IRs
ENC5 & ENC6 Reset globals and restore presets, setlists, and IRs (entire factory restore)
ENC1 & ENC3 Rebuild all presets
ENC1 & ENC5 Clear all presets, setlists, and IRs
ENC1 & ENC6 Will enter Update Mode (This feature is only available on firmware v1.06.5 and higher)

HX Effects

Button Combination Description
Holding FS3 + MODE Will clear all Presets and IRs
Holding FS4+FS5 Will reset Global Settings
Holding FS5+FS6 Will reset Presets only
Holding FS6+TAP Will Perform factory restore (reset, Globals, IRs, and Presets)
Holding the right arrow ">" Will put the unit in a fail safe update mode. Use this when the HX Effects is in an un-recoverable state

HX Stomp

Button Combination Description
All 3 Footswitches Clears all presets/IRs
FS1+2 Resets presets and IRs
FS 2+3 Factory restore (globals, presets, IRs)
  • Thanks 1
Link to comment
Share on other sites

14 minutes ago, PierM said:

I followed every single word and step as described in the sticky update post.

 

I've got a install failure while updating to 2.8 (helix rack, with controller turned off). Also the updated stopped, for an error.

 

Reboot in boot mode and tried again, the install does stop at 5% and fail again.


Tried rolling back to 2.7 or an earlier firmware in boot mode, keep failing at 5%.

 

Please help, this is a fresh unit with 3 days of life....

 

The boot failure is actually part of the 2.8 update process. It should restart automatically and the Updater should continue after that.

 

See Step 3a here:

 

  • Thanks 1
  • Downvote 1
Link to comment
Share on other sites

2 minutes ago, phil_m said:

 

The boot failure is actually part of the 2.8 update process. It should restart automatically and the Updater should continue after that.

 

Yes but after the auto reboot nothing happen. The updater stays there, at 50% stuck forever.


 

  • Like 1
Link to comment
Share on other sites

2 minutes ago, phil_m said:

 

It take a little while from what I remember.

 

Just failed again.


Does fail on the rack before, and reboot, then after a while with the updater red bar (stuck at around 50%), does fail there too.

 

So it's like that;

 

  1. Starts updating, the progress bar arrives at around 50%
  2. Rack show a fail and reboot
  3. Does auto enter in boot mode
  4. progress bar stay there, at 50% for a while (like 5 or 6 minutes)
  5. Updater declare a failed update
Link to comment
Share on other sites

1 minute ago, PierM said:

 

Just failed again.


Does fail on the rack before, and reboot, then after a while with the updater red bar (stuck at around 50%), does fail there too.

 

I would try updating with a different USB port and/or cable.

  • Upvote 1
  • Downvote 1
Link to comment
Share on other sites

2 minutes ago, phil_m said:

 

I would try updating with a different USB port and/or cable.

 

I had a Helix Floor for 3 years, always updated this same way, same cable, same USB port....but I'll follow your advice, at this point I'm starting panicking a bit, so I'll try everything.

 

ty

 

 

Link to comment
Share on other sites

I encountered a similar (perhaps the same) issue during beta testing. The update stopped midway, as I was expecting, and then stalled. Helix Rack would not reboot, and the Updater program would no longer recognize it when connected (i.e. it was not 'enumerating' in Line 6 Updater). Here's the advice I received from Line 6 at that time, and it worked for me:

 

.... if it is not enumerating in Line 6 Updater you may want to try to put it into manual update mode and see if it enumerates. I believe on Rack the shortcut to do so is holding down encoders 1 & 6 while powering on the rack. 

If it still does not enumerate then you may need to try another computer if you have one available. 

 

If you can get it to enumerate, attempt to upgrade to whatever version of firmware it is showing again. (If it shows 2.71 on boot install 2.71 again etc.)

 

I put my Helix Rack in update mode. Line 6 Updater then recognized the device and showed v2.80 firmware installed (even though it did not complete). I restarted the v2.80 update and things proceeded smoothly from there. The update was successfully completed and the Rack was recovered.

 

Hope this helps.

 

 

 

 

  • Thanks 4
Link to comment
Share on other sites

43 minutes ago, silverhead said:

I encountered a similar (perhaps the same) issue during beta testing. The update stopped midway, as I was expecting, and then stalled. Helix Rack would not reboot, and the Updater program would no longer recognize it when connected (i.e. it was not 'enumerating' in Line 6 Updater). Here's the advice I received from Line 6 at that time, and it worked for me:

 

.... if it is not enumerating in Line 6 Updater you may want to try to put it into manual update mode and see if it enumerates. I believe on Rack the shortcut to do so is holding down encoders 1 & 6 while powering on the rack. 

If it still does not enumerate then you may need to try another computer if you have one available. 

 

If you can get it to enumerate, attempt to upgrade to whatever version of firmware it is showing again. (If it shows 2.71 on boot install 2.71 again etc.)

 

I put my Helix Rack in update mode. Line 6 Updater then recognized the device and showed v2.80 firmware installed (even though it did not complete). I restarted the v2.80 update and things proceeded smoothly from there. The update was successfully completed and the Rack was recovered.

 

Hope this helps.

 

 

 

 

 

GOD BLESS YOU!!! 

 

It worked out! The rack wasn't recognized anymore after the reboot, so after a while the updater was stopping the installation with an error.

This time I kept the helix where it was, as I've seen that after restarting the updater the helix was recognized as hosting a 2.8 firmware (even if failed at 50%).

Kept the rack as it was, in its previous state and started the update again. The updater after a bit installed the remaining 50% and completed the process!

 

I took a picture for every step above.

 

IMG-0046.jpg
IMG-0047.jpg
IMG-0050.jpg
IMG-0051.jpg
IMG-0052.jpg
IMG-0053.jpg
IMG-0054.jpg
IMG-0057.jpg
IMG-0058.jpg
IMG-0059.jpg
IMG-0060.jpg
IMG-0061.jpg

 

Thanks everyone!! 

Link to comment
Share on other sites

33 minutes ago, silverhead said:

Is everyone experiencing this problem running Windows 10?

I am. Been stuck at 50% for 90 minutes. Helix Floor. I am afraid to re-boot, and not sure how to access the manual update mode you refernced above. There are others with the same problem on TGP.

Link to comment
Share on other sites

1 minute ago, Rocco_Crocco said:

I am. Been stuck at 50% for 90 minutes. Helix Floor. I am afraid to re-boot, and not sure how to access the manual update mode you refernced above. There are others with the same problem on TGP.

 

Well that kills the Rack unit only theory.

Link to comment
Share on other sites

My LT was stuck at 50 percent...for 3 Hours ! Finally decided to close the Updater, then turn off the LT. Turned LT back on, it showed Version 2,80...but then went into the firnware Upadte screen. Ran the Line 6 Updater again..and it whizzed thru and completed very quickly (maybe 5 mins). The LT has successfully rebooted itself, and is currently rebuilding Presets. Hope this helps someone :)

  • Thanks 1
Link to comment
Share on other sites

16 minutes ago, Rocco_Crocco said:

I am. Been stuck at 50% for 90 minutes. Helix Floor. I am afraid to re-boot, and not sure how to access the manual update mode you refernced above. There are others with the same problem on TGP.

 

The solution for me was TO NOT reboot the helix, but only restart the updater.


If when you restart the updater, it will see your helix as 2.8, means it has been enumerated as 2.8, and you can try installing 2.8 again. It should then start quickly from there, and complete the process in a matter of minutes.

 

Good luck!

  • Like 1
Link to comment
Share on other sites

Bij mij hetzelfde probleem na update 2.80 boot update model 

 

nu herkent de pc de helix niet meer en  zegt de update patch "select device to update" maar de helix kan ik niet zien 

 

 

Edited by lucky1967
correction
Link to comment
Share on other sites

6 minutes ago, Rocles said:

My LT was stuck at 50 percent...for 3 Hours ! Finally decided to close the Updater, then turn off the LT. Turned LT back on, it showed Version 2,80...but then went into the firnware Upadte screen. Ran the Line 6 Updater again..and it whizzed thru and completed very quickly (maybe 5 mins). The LT has successfully rebooted itself, and is currently rebuilding Presets. Hope this helps someone :)

I just followed your advice and it looks like its working. I owe you a pizza!!

  • Like 1
  • Haha 1
Link to comment
Share on other sites

I am using Windows 10 and the Helix Floor and I did not have to restart the Updater. I just hit the "OK" dialog button when it froze (as Line6 said it would) and the update proceeded with no issues. It is rebuilding the presets as we speak. At least for me the update ran exactly according to the Line6 update instructions.

Link to comment
Share on other sites

I have had issues in the past on earlier firmware freezing on the update. I found it was the usb input on the computer that was causing the problem. When I used usb 2.0 it had the problem, when using usb 3.0 it was fine. I am using Helix rack and control and pc running windows 10. I've just done the 2.8 update and it was actually the quickest update I have ever had and no issues at all. 

Link to comment
Share on other sites

32 minutes ago, Dire said:

Same here Helix LT stuck at 50% forever. Tried to restart, now the helix is not recognized anymore by the updater and stuck in boot mode.

Just found out that reinstalling the latest line6 divers e.g. with HX Edit makes the Updater recognize the Helic again. Redid the update. Now everything is fine.

Link to comment
Share on other sites

I restarted the updater and rebooted the helix. But the Helix wasn't regonized after the reboot. (> Shortly before heart attack!!!)

I had to reinstall the complete HelixEdit2.8 package, because something happend to the drivers during the update process. Very strange(=Windows).

But now it begin rebuilding presets. ...phew

Link to comment
Share on other sites

10 minutes ago, BBD_123 said:

I think I'm going to wait a while on 2.8. It's been a time coming, so a few more days is neither here nor there.

I am waiting until tomorrow at least.

Swepco just sent out warnings in text that my location may experience power outages for the next few hours.  

 

I definitely do not want to have something like that go down with a FW update. Especially one that multiple people seem to be having some issue with. 

Link to comment
Share on other sites

hey all
I ran into this issue, too (stopped on "boot failure", helix wasn't recognized by updater), on Windows 10 x64. What helped was uninstalling ALL hx drivers, and reinstall the hx2.80. Doesn't say in the instructions, but well, I'd suggest L6 adds this to some knowhow or faq page

Link to comment
Share on other sites

I don't know if this will help. But as for me, everytime I download new software, my habit was always to restart the pc before opening the software. Never had any issues updating. Did it in 15 mins. Working very good now. Running on Windows 10. 

Link to comment
Share on other sites

10 minutes ago, PierM said:

 

The solution for me was TO NOT reboot the helix, but only restart the updater.


If when you restart the updater, it will see your helix as 2.8, means it has been enumerated as 2.8, and you can try installing 2.8 again. It should then start quickly from there, and complete the process in a matter of minutes.

 

Good luck!

 

Thanks for the post! I got stuck at 50% for half an hour. Restarted the updater per your advice, and it worked!

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

I have the Rack and I'm stuck and can't get past the above Boot Failure screen  

I reinstalled HX updater and edit but still can't get past the Failure screen to reinstall 

How do I Reset to Factory Defaults or initiate Manual Update Mode on the Rack any thing to get me past this Boot Failure screen so Update and Edit  can see the unit again ?

 

Link to comment
Share on other sites

10 minutes ago, MarkeG said:

I have the Rack and I'm stuck and can't get past the above Boot Failure screen  

I reinstalled HX updater and edit but still can't get past the Failure screen to reinstall 

How do I Reset to Factory Defaults or initiate Manual Update Mode on the Rack any thing to get me past this Boot Failure screen so Update and Edit  can see the unit again ?

 

 

Based on what happened to me today, I would suggest this;

  1. Start the Rack while pressing the encoders 1 and 6, this should put the rack into update mode (KEEP THE HELIX CONTROL OFF).
  2. Start the Line 6 updater 1.17 (the latest) and see how your unit is now enumerated (firmware version number)
  3. If does show Helix Rack 2.8, then you can try reinstalling the firmware and see what happens
  4. If does show Helix Rack 2.x, then you should reinstall THAT SPECIFIC firmware; for example, if it's showing Helix Rack 2.7, try reinstalling the firmware 2.7.
  5. If you manage to roll back to a stable firmware just try again the procedure but this time, when the helix reboot itself, DO NOT shut it off, just do NOTHING to it and wait for the updater to finish and/or fail.
  6. If the updater does fail, just keep the Helix as it is (DO NOT TURN IT OFF) and restart the updater.
  7. At this point go back to point 2 again.
  • Upvote 1
Link to comment
Share on other sites

I am 100% busted. Read through all this and nothing helps. Stuck in the Boot failure screen and can't even get Global Reset to work. Says it's initiating then it goes back into the same error.


I take it I now have a $1500 boat anchor?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...