Jump to content
Digital_Igloo

Helix/HX Firmware 2.90 | Helix Native 1.90

Recommended Posts

Helix/HX Firmware 2.90 | Helix Native 1.90

"The Always Level Presets By Ear at Stage Volume with the Rest of the Band Playing Update"

Full update instructions, details, and links here.

 

IMPORTANT! You no longer need to download Line 6 Updater to update your Helix/HX hardware. Just download the latest version of HX Edit, log in, and it'll walk you through the steps. More info in the link above.

Share this post


Link to post
Share on other sites

The "IMPORTANT!" note for Output meters is hilarious.  Basically: "we didn't really want to give you this feature, but you wouldn't shut up about it, so here it is, but you really shouldn't use it anyway.  Please leave us alone."

  • Haha 4

Share this post


Link to post
Share on other sites

Why do i always get the x86 folder as default? Isnt pretty much everyone 64bit by now? Im on a 64 bit OS, but i still just install it in the default x86. Ive never had any problems.

 

 

Share this post


Link to post
Share on other sites

Thanks guys!  I appreciate the hard work.  Pure kismet that I logged on aboot ten minutes after DI posted this.

 

 

(Insert standard 'what's coming in 3.0 and when' - joke here.)

Stay safe!

  • Haha 1

Share this post


Link to post
Share on other sites
2 minutes ago, PiFromBRC said:

(Insert standard 'what's coming in 3.0 and when' - joke here.)

I had to resist the urge as well =D

Share this post


Link to post
Share on other sites

Hi,

 

After 2.9 update volume knob seems to be stuck at whatever level it is set when booting. After a few reboots sometimes the volume knob works for a short time then the whole unit freezes.

Share this post


Link to post
Share on other sites

Hi - trying to install 2.90 but I keep getting an error message when trying to do the backup, see screenshot - any ideas?

 

Many thanks

 

Dave

Screen Shot 2020-04-21 at 18.58.42.png

Share this post


Link to post
Share on other sites
2 hours ago, wiggybass said:

Hi - trying to install 2.90 but I keep getting an error message when trying to do the backup, see screenshot - any ideas?

 

Many thanks

 

Dave

Screen Shot 2020-04-21 at 18.58.42.png


What version of firmware is currently installed in your Helix LT?
 

What happens if you hit Cancel in the the error message dialogue box? Does the firmware update proceed without creating a backup? If so, is it successful?
 

If the firmware update cannot proceed without creating a successful backup file you will need to fix apparent errors, possibly corrupt presets, in your Helix device.  If you don’t have any custom presets or setlists that you want to backup you can just perform a factory reset to restore the Helix device to a state where a system backup will succeed.
 

If you want to make backups of existing presets and setlists, try using HX Edit to export individual setlists. HX Edit v2.90 should be OK to use but if it doesn’t work with your existing firmware revert back to your previous version. Take note of any setlist that fails to export properly. For each such setlist, export all individual presets. Take note of any presets that fail to export properly. 
 

Any presets that failed to export properly are likely corrupt, and are the probable cause of the system backup failure. NOTE: These presets may be irretrievable. You may want to take screenshots at this point to recreate them manually later.
 

Replace each of the above corrupt presets with a copy of New Preset in your setlists. Export the revised setlists. Repeat this procedure until all setlists export successfully.


Now manually create a system backup to ensure that it is successful and won’t halt the firmware update procedure. Then try the firmware update again.

 

Share this post


Link to post
Share on other sites

I've installed Helix Native and all of the new stuff is in there but the about screen still says its version 1.80. Anyone else getting this?

Share this post


Link to post
Share on other sites

Great job Line6 thank you - perfect install on windows 10 Helix LT - rig starts up a lot faster also - appreciate it :)

Share this post


Link to post
Share on other sites

My Mosky two button switch suddenly isn't working after the update. I had fs4 be preset down and fs5 be preset up but now only fs4 works. It won't allow to assign anything to fs5 except bypass all. Anyone else have this issue?

  • Upvote 1

Share this post


Link to post
Share on other sites

As usual, following the update instructions leads to pain and misery. Had to bypass using HXEdit. Line 6 Updater appears to be working fine however....

 

Fingers crossed!

Share this post


Link to post
Share on other sites

So now is it official? (GG)... 

  • Haha 1

Share this post


Link to post
Share on other sites

Flawless update here as well (macOS High Sierra, Mac Pro 5.1).

 

IR recognition by waveform seems to work nicely - just that when I moved one for test purposes, the IR block selected one with another name, which actually *is* the same file, just that I had renamed it. Maybe future FW revisions should check for both the waveform and the filename (I sometimes test some of my own creations and only rename them from "Test_2020_04_13" to something more meaningful later on). Anyhow, an incredible improvement in my book already.

 

Didn't measure before the update, but boot up time seems to be even less than half of what it took with 2.82, so that's really welcomed, especially when re-plugging something during soundcheck (not that there'll be any soundchecks for an unforeseeable amount of time due to that *S)@"§$% Covid thing, but still...).

 

Haven't checked anything else yet, guess it's time for me to get used to Command Center, really like the idea of an even more customized footswitch layout.

 

Oh, there's new toys, too. Might as well check them...

 

Cheers and thanks!

Share this post


Link to post
Share on other sites

FANTASTIC!!

 

Super easy patching, no issues. my Floor definitely boots faster and navigating flows quickly from screen to screen... It feels like some optimizations were done! nice work!

 

Great work on the compressor & gate meters!   I can now see if they are working, or in my case NOT as the majority of my compressors were doing absolutely nothing!!!  With the new visual indicator I was VERY QUICKLY able to find the right thresholds and set where I wanted it to be.  It also appears you fixed the  bug where helix floor would randomly on it's own switch out of STOMP/SNAP footswitch mode, and the only way I could get it back was rebooting between songs.

 

really great work everyone - had a good 2 hours of playing and will keep diving in for more!  I appreciate this great update!

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

Has anyone else noticed that their Variax settings in their snapshots and presets have disappeared since updating? All my tunings etc have gone back to the standard defaults! This is going to take hours to fix!

Edited by merdenoms74
adding further info/clarity
  • Sad 1

Share this post


Link to post
Share on other sites

Has been mentioned in the bug report thread already: Tap Tempo for delays is completely broken. Major showstopper for myself. How do I revert to 2.82 the easiest way?

And if this is broken indeed (wouldn't happen to know what could be user error, always worked as supposed), how could it be overlooked during testing?

 

Edit: Only seems to be broken in "authentic" mode, when set to "transparent", things seem to be fine. I'd take a bet it was fine in either mode under 2.82.

Share this post


Link to post
Share on other sites

I did a "Restore From Backup" and all my Variax settings reappeared.

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, wiggybass said:

If you experience problems with the update due to corrupt presets. ? This is what worked for me..
1. Backup the factory presets and your presets that work correctly.
2. There is an option to restore all the presets by leaving all libraries in blank. This is the only effective way to remove corrupt presets.
3. Now you can do the update without any problem.
4. import your personal and factory presets and voila
Regards

 

7 hours ago, wiggybass said:

 

 

Share this post


Link to post
Share on other sites

@dukegdl 

Corrupted presets: does that look like the helix stopping the rebuild on a particular preset... say, preset 37??

 

Never mind.. I just cycled the power on the Helix and it just woke up and started rebuilding presets from where it left off..

wait.. a... second... now it stopped on Preset #49... 

cycled power again and it started again.. passed preset 140 and still going.

 

 

Share this post


Link to post
Share on other sites
5 hours ago, Schivosa said:

I've installed Helix Native and all of the new stuff is in there but the about screen still says its version 1.80. Anyone else getting this?

 

Did you install both HX Edit and Helix Native? They are still separate downloads although the new naming convention has each referring to the other.  If you did install both already then I would probably reinstall Native 1.9.

 

I'm not getting anything about 1.80. The message in the Help/About reads like this when properly updated:

"Helix Native 1.90

Helix 2.90 Compatible "

Share this post


Link to post
Share on other sites
2 hours ago, lcbrow said:

I did a "Restore From Backup" and all my Variax settings reappeared.

 

Go to the Input block on any preset that is set for Variax. Go to the second page of the parameters and set 'Variax Settings' = "Per Preset".  Now save that preset. You should now have all your Variax settings back on all your presets. This is a Line6 idiosyncrasy that has been around for a while. Although 'Variax Settings' is located in a preset, it is actually a global setting.

  • Like 1

Share this post


Link to post
Share on other sites

Seamless install. Easiest one yet. One note, it did seem to reset all my global settings to their defaults. Looking forward to checking out the new firmware and editor. Thanks Line6!

Share this post


Link to post
Share on other sites

Wow. I didn't expect an update during the covid thing. Great job! Thanks a lot, Dev team! Gonna update after finishing my coffee.

 

Now here's hoping for the next update to be "The Polyphonic Update" :D

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Unfortunately my HX Effects is not being recognized by now 2 computers and I've tried 4 different USB cables. Worrying that this unit may be having problems...

Share this post


Link to post
Share on other sites

Flawless update here. Fortunately had no issues with tap tempo or volume knob as other people report, love the new phaser, and boot time has gone from 20 to 10 seconds! Amazing job. Thanks again for your hard work.

Share this post


Link to post
Share on other sites

HI, 

for me a big problem appear... 

the update fails during the installation and now the Helix can't connect to the computer anymore. So i can't do the update one more time with HelixEdit

IMG_2804.thumb.jpg.83e1eb5f4319d4b428c024bc2aaf93ed.jpg

 

 

 

 

 

 

 

 

on the Helix, i've got this message:

IMG_2803.thumb.jpg.348bf7fcac258ca90879895b0d4f60fd.jpg

 

 

I try to shut down the Helix, close the HelixEdit and restart connect the Helix but nothing change... 

 

I've no idea what to do??? 

 

BTW: the firmware updater don't work anymore, the software don't start anymore...

 

Please Help, I can't play guitar anymore during quarantine !!! :-( 

Spoiler

 

 

Share this post


Link to post
Share on other sites

Windows 10.

 

Installed without a hitch. Also Helix Native.

 

Now to see how the Small Stone sounds and take a look at these GR meters - at last!

 

Thank you to all at Line 6. This can't have been easy, but I think most of us are grateful to you for managing to keep supporting us at this time. Well done, guys.

Share this post


Link to post
Share on other sites

Worst thing about this update is that it's a question of time for me to getting anxious about a desirable polyphonic update lol

Share this post


Link to post
Share on other sites
18 hours ago, chasingMango said:

The "IMPORTANT!" note for Output meters is hilarious.  Basically: "we didn't really want to give you this feature, but you wouldn't shut up about it, so here it is, but you really shouldn't use it anyway.  Please leave us alone."

 

I'm glad we finally got this, but I'd really like (a) the Output Meter to also be in HX Edit, not just on the device itself, and (b) to have an actual graduated meter with numerical readings.  I play in a band where I use 12 or more patches (and 3-4 snapshots per patch) during the course of a show and have always been frustrated by the trial-and-error approach to level matching them all by ear.  The Output Meter certainly helps, but a graduated meter in HX Edit would be ideal.  Is there a particular thread on this forum for enhancement requests?  Was poking around briefly this morning but didn't see it.

  • Like 1

Share this post


Link to post
Share on other sites

I tried to import an IR with HX Edit that worked fine in 2.8, now upon import the IR just flashes a message (so fast I can not read it), and the IR slot still reads "Empty". IR's should still work the same between versions, right? I am not sure why this IR won't import now?

 

I noticed there is one IR in slot #1 that is blank that I can not remove. It will let me import a new one in slot #1, but none of the others will allow an import. I am bummed I have no IR's available?!

 

BTW..... volume knob works fine, everything else seems OK so far, but I have not got to play with it much yet.

 

Thanks!

Dave

 

UPDATE: I reset the Helix (with V2.9) to the factory Defaults, it DID remove the IR in slot #1, but when trying to load IR's, same issue, Slot #1 would allow me to add an IR (but after I could not clear it), and the remaining slots would not.

 

I re-installed 2.82, all IR's locations allow me to import/copy/clear without issue.

 

Once again, I  re-installed 2.9 (for the 3rd time) and my IR slots were all < EMPTY > except for slot #1, which is occupied and Blank (un-named) and it would not allow me to clear it, copy it, or upload an IR into any other locations. If I applied that IR to a block, I could not remove that block without receiving the error seen in the image below.

 

I have now went back to 2.82, and will stay until things are fixed.
image.thumb.png.e12a47018ceb62bb0824abe97c5572e2.png

Share this post


Link to post
Share on other sites
1 hour ago, palladinojt said:

 

I'm glad we finally got this, but I'd really like (a) the Output Meter to also be in HX Edit, not just on the device itself, and (b) to have an actual graduated meter with numerical readings.  I play in a band where I use 12 or more patches (and 3-4 snapshots per patch) during the course of a show and have always been frustrated by the trial-and-error approach to level matching them all by ear.  The Output Meter certainly helps, but a graduated meter in HX Edit would be ideal.  Is there a particular thread on this forum for enhancement requests?  Was poking around briefly this morning but didn't see it.

You bring HX Edit to a gig?  Anyway at a show isn't the sound guy looking at meters on the board (as well as using his ear?)

Share this post


Link to post
Share on other sites
8 minutes ago, chasingMango said:

You bring HX Edit to a gig?  Anyway at a show isn't the sound guy looking at meters on the board (as well as using his ear?)

 

I do not bring HX Edit to a gig.  I typically try to have all my patches prepared before a gig, and do the vast majority of my patch creating/editing at my PC rather than on the front face of the device.  The sound guy at the venue isn't the issue.  If you were using a traditional pedal board and for example had a second drive pedal for a lead boost, wouldn't you try to set the output on that pedal to the appropriate level for its intended purpose?  If you engaged that pedal and it was too loud would you just say "eh - that's the sound guy's problem"?  I try my best to have the unit set up, prior to a gig, so that clean tones, driven rhythm tones, lead tones, etc, are all appropriately balanced with respect to one another.  The sound guy can set the guitar where it needs to be and the patches can take care of themselves, rather than him having to ride the fader all night.

Share this post


Link to post
Share on other sites

Just installed 2.9 and having the same issue with volume knob not working.  I checked global settings and it is set to multi.  Also seem to have lost 8 switch stomp box mode option?

Share this post


Link to post
Share on other sites

I am trying to follow the instructions. Updated HX Edit to 2.90.

 

But it is unable to update my HX Stomp which is at 2.82. Getting a "Unable to open backup dialog" error. This is on a MacBook Pro running latest Catalina.

2020-04-22_15-50-16.png

Share this post


Link to post
Share on other sites

I'd like to congratulate the  entire team @ L6  for this update. 

the update process is much improved and the quality of the experience updating was very good. 

some simple GUI and workflow improvements are also appreciated. 

 

The helix keeps me playing and inspired with less "fiddling" and that was a goal for me.   Thank you.  

 

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...